Plasahosting Blogs
Web Hosting murah Indonesia

Cara Upgrade Joomla 1.5 ke 3.x

May 3rd 2014 in Artikel

Bagaimana cara meng-upgrade dari Joomla ! 1,5 untuk 3.x ?
Dari Joomla ! dokumentasi

Sebelum melakukan upgrade lakukan BACKUP-BACKUP-BACKUP terlebih dahulu.

METODE OTOMATIS

Dukungan untuk Joomla 1.5 telah resmi berakhir . Apakah itu berarti situs 1,5 Anda akan berhenti bekerja ? Tidak, situs Anda akan terus bekerja seperti biasanya . Namun, pengembang Joomla tidak akan merilis versi baru untuk Joomla 1.5 , sehingga Anda tidak akan mendapatkan perbaikan bug atau perbaikan keamanan . Untuk alasan ini , dianjurkan untuk bermigrasi dari 1,5 .

Pindah dari 2,5 ke versi Joomla 3 relatif sederhana , karena Joomla telah membuat proses mudah untuk versi yang lebih baru . Sayangnya , bergerak dari 1,5 bukanlah tugas yang sepele . Untungnya, ada dua ekstensi yang baik yang membuat proses lebih mudah : jUpgrade dan SP Upgrade.

Anda memiliki pilihan untuk pergi langsung ke Joomla 3.0 atau pergi ke 2,5 pertama . Kedua upgrade SP dan jUpgrade memiliki versi siap untuk kedua versi . Silakan berkonsultasi dengan dokumentasi mereka tentang bagaimana untuk bermigrasi dari Joomla 1.5 ke 3.0/2.5 .

Bermigrasi ke Joomla 3.0 jika semua ekstensi yang Anda berencana untuk menggunakan adalah Joomla 3.0 kompatibel . Hanya beberapa penyedia template atau vendor ekstensi akan siap untuk Joomla 3.0 pada saat peluncuran , namun sebagian besar tidak akan siap sampai hari , minggu atau bulan setelah . ( Lihat ” Bagaimana saya menemukan Joomla 3.0 ekstensi kompatibel ? ” FAQ untuk informasi lebih lanjut )

Bermigrasi ke Joomla 2.5 jika Anda ingin yang paling stabil yang Joomla yang ditawarkan dan / atau jika Anda berencana untuk menggunakan banyak ekstensi .

METODE MANUAL

Jika Anda lebih suka lebih ‘ Hands on ‘ pendekatan maka Anda dapat bermigrasi secara manual .

1. Instal Akeeba Backup pada 1,5 dan membuat cadangan . (versi kompatibilitas )
2. Gunakan http://archive.extensions.joomla.org/extensions/migration-a-conversion/data-import-a-export/12816 untuk mengekspor Artikel dan pengguna . Bila Anda memilih Bagian yang itu ekspor semua Kategori terkait dan Artikel dan menciptakan bagian / kategori sebagai kategori / sub kategori .
3. Instal Joomla 2.5.x ( atau 3.xx ) tanpa data sampel dalam subdirektori
4. Kemudian mengimpor data sebelumnya diekspor dari 1,5 ke 2.5.x segar ( atau 3.xx ) dengan J2XML Importir
5. Instal Akeeba Backup di Joomla baru Anda ! 2.5/3.5 dan membuat cadangan
6. Buat item menu dan menginstal ekstensi
7. Buat backup pada tahap biasa
8. Bila sudah siap menghapus semua yang ada di root ( kecuali folder baru) dan memindahkan Joomla naik tingkat , lihat Pindah situs antara direktori / sub – direktori untuk petunjuk .

( NB situs aktip var mungkin tidak memiliki nilai , jika itu terjadi maka meninggalkannya dengan tidak ada nilai )

Jika pada # 3 Anda menginstal Joomla di localhost kemudian di # 8 Anda dapat menggunakan file cadangan untuk menginstal situs baru pada akar Host

 

Sumber terjemahan:

http://docs.joomla.org/How_do_I_upgrade_from_Joomla!_1.5_to_3.x%3F




required



required - won't be displayed


Your Comment:




Joomla Fatal error: Cannot redeclare quoted_printable_encode() in vcard.class.php
Penyebab:

Joomla tidak compatible dengan versi PHP 5.3.x

Cara mengatasi:

Buka file  includes/vcard.class.php

Cari: function quoted_printable_encode
tambahkan diatasnya:

if(!function_exists(‘quoted_printable_encode’)) {

dan tambahkan dibagian bawah fungsi tanda:

}

Kode akan menjadi:

if(!function_exists(‘quoted_printable_encode’)) {
function quoted_printable_encode($input, $line_max=76) {
/* … */
}
}

Previous Entry

FTP server menggunakan SSL/TLS encryption untuk mengacak user dan password yang dikirimkan ke server. Bila anda menemukan pesan:

Sorry, cleartext sessions are not accepted on this server  seperti di gambar:

lakukan penambahan kalimat ftpes:// didepan host anda.

contoh: ftpes://namadomainanda.com lihat gambar bulatan warna merah

 

 

 

 

Next Entry